Minecraft Server Update
Incident Report for Trigon.Systems Status
Resolved
This incident has been resolved.
Posted Sep 15, 2021 - 17:05 UTC
Identified
The minecraft server is under maintenance to update from 1.15.2 to 1.17.1
Posted Sep 13, 2021 - 17:09 UTC